урок-"VRayProxy"

http://www.evgen-64.narod.ru

3ds max ….. и все что с ним связано.

урок-"VRayProxy" :

(проверьте что у Вас в 3ds Max установлен визуализатор VRay версии не ниже 1.48.03...), в визуализаторе Vray появилось много новшеств, про одно из них (очень нужное всем максерам) я хочу расказать в этом уроке.

В последних версиях визуализатора VRay (1.48.03... и выше) появился новый обьект VRayProxy. Он позволяет преобразовывать сетку обьекта сцены 3dsmax в фаил с расширением .vrmesh и хранить информацию о преобразованном обьекте отдельно от сцены. Этот файл (.vrmesh) содержит всю информацию о геометрии сетки преобразованного обьекта - а также каналы текстур, IDs материала, группы сглаживания, нормали - короче говоря, все, что - нужно для отображения и визуализации преобразованного обьекта. Кроме того, сетка разбита на куски для облегчения ее загрузки и просчета. Файл также содержит упрощенную версию сетки используемой для предварительного просмотра в viewports. Обьект VRayProxy просто необходим для сцен с большим количеством полигонов, геометрия обьекта VRayProxy не присутствует в 3dsmax сцене и не требует ресурсы компьютера. Это допускает создавать сцены со многими миллионами треугольников - более, чем 3dsmax сам может справится.
...

Ну, а теперь познакомимся поближе с VRayProxy, создайте любую тестовую сцену (см. рис.1) или загрузите мою (сцена для 3dsMax8-архив WinRAR-90кб), (для загрузки щелкните по рис.1). В сцене присутствуют 4-ре примитива шар, куб, цилиндр, плоскость и ветка растения, а так же источник света Omni. Всем сетчатым обьектам присвоенны материалы с теми же названиями. Я не стал делать более сложную сцену, для примера подойдет и такая. (Визуализируйте сцену и сохраните ее, для сравнения). Теперь проверим сколько полигонов (треугольников) присутствует в нашей сцене. Для этого воспользуемся утилитой Polygon Count которая расположена Utilities>More>Polygon Count>OK, (см рис.2) откроеться окно Polygon Count, где и бедет указанно колличество треугольников в сцене ( в моем случае это 15172 треугольных элимента), запомните или запишите эту цифру (если вы используете собственоручно созданную сцену то эта цифра у Вас будет другой). Закройте утилиту Polygon Count нажав на кнопку Close.

Для уменьшения колличества полигонов(треугольников) в сцене воспользуемся обьектом VRayProxy и применим его к ветке, так как она имеет наибольшее колличества полигонов (треугольников), для этого выделяем ветку, щелкаем по ней пр. кн. мыши и в открывшемся контекстном меню (в самом низу) выбираем пункт VRay mesh export, откроется окно VRay mesh export (см. рис.3).

В полеFolder указывается путь к папке где будет сохранен файл по умолчания это ....:\3dsMax8\meshes, (но Вы можете изменит его нажав кнопку Browse). Если установлен переключатель Export as a single file то доступно поле File где можно указать имя сохраняемого файла, (по умолчанию файлу присваевается имя преобразуемого обьекта). Если установлен переключатель Export as multiple files, то поле становится недоступным и всем приобразуемым обьектам автоматически присваються их первоначальные названия. Обязательно поставьте галочку Automatically create proxies, чтобы обьект VRayProxy был создан автоматически и нажмите ОК.

Теперь еще раз проверим сколько полигонов (треугольников) присутствует в нашей сцене. Для этого повторно воспользуемся утилитой Polygon Count, так же как мы делали это раньше. Результат налицо было 15172 треугольных элимента, а стало 1412, геометрия сцены значительно облегчена. Повторно выполните визуализацию и сравните с первой, (см рис.5), лично я отличий не нашел, а это говорит о том что теперь можно создавать сцены с очень большим колличеством моделей не опасаясь что компьютер зависнет или будет тормозить!!!

...

Закройте утилитуPolygon Count нажав на кнопку Close. Выделите в любом окне проекции ветку, правда теперь она называется VRayProxy_ветка перейдите на вкладку Modiffy, (см рис.6). У обьекта VRayProxy только один свиток с параметрами MeshProxy params. Кнопка Browse предназначена для загрузки ранее сохраненных файлов с расширением .vrmesh , в окне ниже отображается путь к загруженному файлу, группа переключателей Display отвечает за отображение обьекта VRayProxy в окнах проэкции, (на визуализацию сцены влияния не оказывают ). Если установить переключатель bounding box то обьект VRayProxy будет отображаться как обычный бох, если установить переключатель в положение preview from file то в окнах проэкции будет отображатся упрощеная модель обьекта до его преобразования, которая сохраняется вместе с .vrmesh файлом.

Примечания:

- Геометрия сгенерированная объектом VRayProxy не модифицируемая. Любые модификаторы примененные к объекту VRayProxy будут проигнорированы.

- В настоящее время, файл .vrmesh не может сохранить амимацию сетки.

- Результирующие .vrmesh файлы могут предоставлять вне 3dsmax - например, автономной версией визуализатора VRay.

- Используйте VRay тени.

- для загрузки ранее созданного файла .vrmesh необходимо создать обьект VRayProxy, (см рис.7) Greate>Geometry>из списка выбратьVRay>нажать кнопку VRayProxy , щелкнуть в окне проэкции Top, откроется окно Choose external mesh file и открыть ранее созданный файл с расширением .vrmesh.
Удачи, если возникнут вопросы пишите.

Урок написан по материалам сайта http://www.Chaosgroup.com.